1. Home
  2. Docs
  3. Getting Started
  4. Technical Requirements

Technical Requirements

Chamber Dashboard themes & plugins require a self-hosted WordPress.org installation.

We recommend using the most up-to-date version of WordPress.

Before installing WordPress & Chamber Dashboard themes & plugins, you should first verify that your hosting environment* is running the minimum requirements as recommended by WordPress. The current system requirements for Chamber Dashboard are:

  • Self-hosted WordPress Installation, version 5.2+
  • PHP version 7.0 +
  • MySQL version 5.6 +
  • HTTPS support
  • Chron jobs

*Hosting plays a big role in how your site runs. If your site is slow, try a caching plugin. If that does not help, try reaching out to your hosting company to make sure your account is set up correctly.

NOTE: Older, unsupported versions of PHP can be a security risk to your site. If the version of PHP that your site is using is not listed under ‘Currently Supported Versions’ on the php.net supported versions page we recommend updating to a more recent version. Your web host should be able to assist you in updating your PHP to a more recent version. How to find your current PHP version.

See how Chamber Dashboard plugins work with Gutenberg, WordPress 5.0 block editor

Was this article helpful to you? Yes No